Language:
Page Info
Engine Version:
The translation of this page is out of date. Please see the English version for the latest version of the page.

Lumin Development Requirements

In this page you'll find hardware and software development kit (SDK) requirements needed to start developing for the LuminNEW! platform. 

Unreal Engine 4.22

Hardware Requirements

Recommended Desktop Hardware

See Magic Leap's Developer System Requirements .

Supported VR Headset

Magic Leap One

Software Requirements

Desktop Operating System

Windows 10 64-bit or later.
MacOS 10.11 or later.
See Magic Leap's Developer System Requirements .

SDK Version

0.19.0

The currently supported SDK version(s) can be found in UEBuildLumin.cs. You can find it in your [UE4 Root Director]/Engine/Source/Programs/UnrealBuildTool/Platforms/Lumin folder.

Unreal Engine 4.21

Hardware Requirements

Recommended Desktop Hardware

See Magic Leap's Developer System Requirements .

Supported VR Headset

Magic Leap One

Software Requirements

Desktop Operating System

Windows 10 64-bit or later.
MacOS 10.11 or later.
See Magic Leap's Developer System Requirements .

SDK Version

0.16.0

The currently supported SDK version(s) can be found in UEBuildLumin.cs. You can find it in your [UE4 Root Director]/Engine/Source/Programs/UnrealBuildTool/Platforms/Lumin folder.

Unreal Engine 4.20

Hardware Requirements

Recommended Desktop Hardware

See Magic Leap's Developer System Requirements .

Supported VR Headset

Magic Leap One

Software Requirements

Desktop Operating System

Windows 10 64-bit or later.
MacOS 10.11 or later.
See Magic Leap's Developer System Requirements .

SDK Version

0.12.0

The currently supported SDK version(s) can be found in UEBuildLumin.cs. You can find it in your [UE4 Root Director]/Engine/Source/Programs/UnrealBuildTool/Platforms/Lumin folder.